Upgrading PaperCut MF & NG (upgrade procedure)

KB Home   |   Upgrading PaperCut MF & NG (upgrade procedure)

Main.Upgrading History

Hide minor edits - Show changes to output

July 23, 2019, at 12:07 PM by Jack Lawless - Added Chargeback upgrade section
Added lines 12-15:

Q: I'm a PaperCut Chargeback customer, how do I move up to PaperCut NG?

A: No problem, we have a KB on this [[https://www.papercut.com/kb/Main/UpgradingChargeBack|here]].
July 23, 2019, at 12:04 PM by Jack Lawless - Grammar, typos, expanded sections from customer feedback. Purged Matt Lee from existence.
Changed lines 9-10 from:
A: If it's your first update on a production system, you may find some of our Technical Solutions team practical advice useful:  [[https://blog.papercut.com/when-software-updates-go-wrong-a-horror-story/|See his blog post on managing updates]]
to:
A: If it's your first update on a production system, you may find some of our Technical Solutions team's advice on [[https://blog.papercut.com/when-software-updates-go-wrong-a-horror-story/|managing updates]] useful.
Changed lines 13-16 from:
Q: Can I upgrade straight from e.g. 12.x to 16.x or do I have to apply intermediate upgrades?

A: PaperCut is designed to support "install over the top" upgrades from ''any'' version to ''any newer'' version.
to:
Q: Can I upgrade straight from e.g. 16.x to 19.x or do I need to go for staggered upgrades?

A: Yes, you can! PaperCut is designed to support "install over the top" upgrades from ''any'' version to ''any newer'' version.

However, from a best practices point of view, if you're on quite an old version (say v12 and before) and are looking to move straight up to our latest version, you would be better off minimising the risk of the upgrading accidentally failing by staggering your updates. The best judge of this is check whether there's been a large number of [[https://www.papercut.com/kb/Main/DatabaseSchema|database schema]] changes or [[https://www.papercut.com/search/?q=release+history|features implemented]] between versions. If it seems like a lot we would recommend a staggered upgrade approach, e.g. v15 -> v17-> v19. Obviously, a easy way to mitigate this risk is by taking a [[https://www.papercut.com/kb/Main/BackingUpData|backup]] of your server or PaperCut install beforehand.

If you need help accessing interim release versions of PaperCut for a staggered upgrade, as a MF customer, you will need to contact your PaperCut Reseller. As a NG customer, please contact our Technical Solutions team over  [[https://www.papercut.com/support/|here]]
.
Changed lines 23-24 from:
A: Please look at our [[PaperCutServerSizingGuide |  server sizing guide]] to make sure that your system can perform adequately when supporting the newer features in current versions of PaperCut Mf & NG?
to:
A: Please look at our [[PaperCutServerSizingGuide |server sizing guide]] to make sure that your system can perform adequately when supporting the newer features in current versions of PaperCut NG/MF.
Changed lines 39-41 from:
If you are using a licensed version of PaperCut NG, you can upgrade to the latest version at:

->https:
//www.papercut.com/products/ng/upgrade/
to:
If you are using a licensed version of '''PaperCut NG''', you can upgrade to the latest version [[https://www.papercut.com/products/ng/upgrade/|here]].
Changed lines 41-43 from:
If you have PaperCut MF then you can obtain the installation software from your PaperCut business partner (reseller), or via the Check for Updates function, which is found on the About tab of your PaperCut administration console. Please note that customer self-service upgrades are only recommended for server and workstation components.
If you are migrating from PaperCut NG to PaperCut MF, then contact your reseller for support as this upgrade procedure does not apply.
to:
If you have '''PaperCut MF''' then you can obtain the installation software from your PaperCut Authorised Reseller, or via the @@Check for Updates@@  option found on the About tab of your PaperCut administration console. Please note that customer self-service upgrades are only recommended for server and workstation components.

If you are migrating from PaperCut NG to PaperCut MF, then contact your PaperCut Authorised Reseller for support as this upgrade procedure does not apply.
Changed lines 61-63 from:
-->[@C:\Program Files\PaperCut NG\@] ([@C:\Program Files\PaperCut MF\@] if using PaperCut MF)
to:

-->[@C:\Program Files\PaperCut NG\@] (if using PaperCut NG)
-->[@C:\Program Files\PaperCut MF\@] (
if using PaperCut MF)
July 23, 2019, at 10:57 AM by Jack Lawless - Removed One Time Upgrade KB reference - deprecated.
Changed lines 9-11 from:
A: If it's your first update on a production system, you may find some of Matt Lee's practical advice useful:  [[https://blog.papercut.com/when-software-updates-go-wrong-a-horror-story/|See his blog post on managing updates]]

Also, make sure you're eligible for an upgrade. Have you got current [[https://www.papercut.com/products/ng/premium-upgrade-assurance/|Maintenance and Support (M&S)]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade]]?
to:
A: If it's your first update on a production system, you may find some of our Technical Solutions team practical advice useful:  [[https://blog.papercut.com/when-software-updates-go-wrong-a-horror-story/|See his blog post on managing updates]]

Also, make sure you're eligible for an upgrade; have you got current [[https://www.papercut.com/products/ng/premium-upgrade-assurance/|Maintenance and Support (M&S)]]?
March 31, 2019, at 04:27 AM by timg - M&S Updates
Changed line 11 from:
Also, make sure you're eligible for an upgrade. Have you got [[https://www.papercut.com/support/premium-upgrade-assurance|Premium Upgrade Assurance]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade]]?
to:
Also, make sure you're eligible for an upgrade. Have you got current [[https://www.papercut.com/products/ng/premium-upgrade-assurance/|Maintenance and Support (M&S)]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade]]?
March 19, 2019, at 06:34 AM by peterf - Added reference to new 32-bit KB
Changed line 51 from:
->'''1.''' If upgrading from a previous major release (e.g. version 14 or earlier), first [[UpgradePolicy | check your eligibility to upgrade]].
to:
->'''1.''' If upgrading from a previous major release (e.g. version 14 or earlier), first [[UpgradePolicy | check your eligibility to upgrade]]. If you still accommodate any 32-bit workstations in your environment and are upgrading from version 18.3 or earlier to version 19.0 or later, check out our [[EndOfLife32BitOperatingSystems|+]] article for an important caveat.
December 11, 2018, at 10:16 PM by Dug - Amended "your" to "you're" in first answer
Changed line 11 from:
Also, make sure your eligible for an upgrade. Have you got [[https://www.papercut.com/support/premium-upgrade-assurance|Premium Upgrade Assurance]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade]]?
to:
Also, make sure you're eligible for an upgrade. Have you got [[https://www.papercut.com/support/premium-upgrade-assurance|Premium Upgrade Assurance]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade]]?
Added lines 46-48:
''Please note: Upgrading instructions are the same for Linux, Mac, Windows, Novell. You just need to install the latest version "over the top". Please follow the steps listed in [[https://www.papercut.com/support/resources/manuals/ng-mf/common/topics/install.html| this]] section of the manual for installation instructions for each operating system.''

Deleted line 69:
''Please note: Upgrading instructions are the same for Linux, Mac, Windows, Novell. You just need to install the latest version "over the top". Please follow the steps listed in [[https://www.papercut.com/support/resources/manuals/ng-mf/common/topics/install.html| this]] section of the manual for installation instructions for each operating system.''
December 10, 2018, at 03:56 PM by Priyanka - Added information about how upgrading instructions are same for all operating systems
Added lines 66-67:

''Please note: Upgrading instructions are the same for Linux, Mac, Windows, Novell. You just need to install the latest version "over the top". Please follow the steps listed in [[https://www.papercut.com/support/resources/manuals/ng-mf/common/topics/install.html| this]] section of the manual for installation instructions for each operating system.''
November 18, 2018, at 10:57 PM by TimG - Added note about Known Issues
Added lines 20-21:

It's also worth checking out the latest information on [[https://www.papercut.com/kb/Main/KnownIssues|PaperCut NG/MF Known Issues]] to make sure you know what to expect with the new version.
April 17, 2018, at 02:02 PM by Matthew Lee -
Changed line 9 from:
A: If it's your first update on a production system, you may find some of Matt Lee's practical advise useful:  [[https://blog.papercut.com/when-software-updates-go-wrong-a-horror-story/|See his blog post on managing updates]]
to:
A: If it's your first update on a production system, you may find some of Matt Lee's practical advice useful:  [[https://blog.papercut.com/when-software-updates-go-wrong-a-horror-story/|See his blog post on managing updates]]
April 17, 2018, at 01:36 PM by Matthew Lee -
Changed line 11 from:
Also, make sure your eligible for an upgrade. Have you got [[https://www.papercut.com/support/premium-upgrade-assurance|Premium Upgrade Assurance]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade}}?
to:
Also, make sure your eligible for an upgrade. Have you got [[https://www.papercut.com/support/premium-upgrade-assurance|Premium Upgrade Assurance]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade]]?
April 17, 2018, at 01:30 PM by Matthew Lee -
Added lines 6-11:

Q: Where do I start?

A: If it's your first update on a production system, you may find some of Matt Lee's practical advise useful:  [[https://blog.papercut.com/when-software-updates-go-wrong-a-horror-story/|See his blog post on managing updates]]

Also, make sure your eligible for an upgrade. Have you got [[https://www.papercut.com/support/premium-upgrade-assurance|Premium Upgrade Assurance]] or a [[https://www.papercut.com/products/ng/upgrade-pricing/|One Time Upgrade}}?
April 17, 2018, at 10:26 AM by 90.152.8.32 -
Changed line 5 from:
(:youtube kQLMl3lRZK0&t=99s:)
to:
(:youtube kQLMl3lRZK0:)
April 17, 2018, at 10:25 AM by 90.152.8.32 -
Added lines 2-5:

The video below demonstrates the processes involved in upgrading PaperCut MF & NG.

(:youtube kQLMl3lRZK0&t=99s:)
Added lines 6-9:

Q: Is there any preparation I should complete before the upgrade?

A: Please look at our [[PaperCutServerSizingGuide |  server sizing guide]] to make sure that your system can perform adequately when supporting the newer features in current versions of PaperCut Mf & NG?
Changed line 22 from:
to:
 
December 07, 2016, at 09:01 PM by 139.130.165.134 -
Changed line 23 from:
If you have PaperCut MF then you can obtain the installation software from your PaperCut business partner (reseller), or via the Check for Updates function. Please note that customer self-service upgrades are only recommended for server and workstation components.
to:
If you have PaperCut MF then you can obtain the installation software from your PaperCut business partner (reseller), or via the Check for Updates function, which is found on the About tab of your PaperCut administration console. Please note that customer self-service upgrades are only recommended for server and workstation components.
August 23, 2016, at 06:22 AM by Geoff - Update the explanatory text for payment gateway download
Changed line 68 from:
-> PaperCut version 15.0 to 16.1 are not compatible with older versions of the PaperCut Payment Gateway. You should upgrade to the latest version. Download the latest version from below: 
to:
-> Customers running PaperCut 15.0 to 16.1 can download the payment gateway from here:
August 23, 2016, at 06:17 AM by 139.130.165.134 -
Changed lines 59-60 from:
-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module.exe|pcng-payment-gateway-module.exe]]
to:
-> [[https://www.papercut.com/download/?http=https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module.exe|pcng-payment-gateway-module.exe]]
Changed lines 63-65 from:
-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module.tar.gz|pcng-payment-gateway-module.tar.gz]]

to:
-> [[https://www.papercut.com/download/?http=https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module.tar.gz|pcng-payment-gateway-module.tar.gz]]

Changed lines 72-73 from:
-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-16.0.225.exe|pcng-payment-gateway-module-16.0.225.exe]]
to:
-> [[https://www.papercut.com/download/?http=https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-16.0.225.exe|pcng-payment-gateway-module-16.0.225.exe]]
Changed lines 76-78 from:
-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-16.0.225.tar.gz|pcng-payment-gateway-module-16.0.225.tar.gz]]

to:
-> [[https://www.papercut.com/download/?http=https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-16.0.225.tar.gz|pcng-payment-gateway-module-16.0.225.tar.gz]]

Changed lines 85-86 from:
->[[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-14.3.30038.exe|pcng-payment-gateway-module-14.3.30038.exe]]
to:
->[[https://www.papercut.com/download/?http=https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-14.3.30038.exe|pcng-payment-gateway-module-14.3.30038.exe]]
Changed line 89 from:
-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-14.3.30038.tar.gz|pcng-payment-gateway-module-14.3.30038.tar.gz]]
to:
-> [[https://www.papercut.com/download/?http=https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-14.3.30038.tar.gz|pcng-payment-gateway-module-14.3.30038.tar.gz]]
August 23, 2016, at 06:10 AM by 139.130.165.134 -
Changed line 72 from:
-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/ pcng-payment-gateway-module-16.0.225.exe|pcng-payment-gateway-module-16.0.225.exe]]
to:
-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-16.0.225.exe|pcng-payment-gateway-module-16.0.225.exe]]
August 23, 2016, at 03:40 AM by 139.130.165.134 -
Added lines 1-101:
(:title Upgrading PaperCut MF & NG (upgrade procedure):)

Q: Can I upgrade straight from e.g. 12.x to 16.x or do I have to apply intermediate upgrades?

A: PaperCut is designed to support "install over the top" upgrades from ''any'' version to ''any newer'' version.

Q: Can I upgrade the Application Server but keep the clients and secondary servers on a previous version?

A: The PaperCut Application Server is designed to be backwards compatible, so you can have a newer version of the Application Server being used with older versions of the Secondary Servers, Release Stations, and Clients for the purposes of the upgrade. However, we highly recommend upgrading those other components to match the primary Application Server as soon as possible, so that you gain the benefits of upgrading all the components in your environment.

You cannot have an older version of the Application Server being used with a newer version of the Secondary Server, Release Station, or Client software.

Q: Is the same true for Site Servers?

A: If you have Site Servers, they must be maintained at the same version as your Application Server. Site Servers have an especially close relationship with the Application Server and it is not possible to support older versions of the Site Server. When your Application Server is upgraded, your Site Servers will operate in offline mode until they are also upgraded.

!The Upgrade Process

If you are using a licensed version of PaperCut NG, you can upgrade to the latest version at:

->https://www.papercut.com/products/ng/upgrade/

If you have PaperCut MF then you can obtain the installation software from your PaperCut business partner (reseller), or via the Check for Updates function. Please note that customer self-service upgrades are only recommended for server and workstation components.
If you are migrating from PaperCut NG to PaperCut MF, then contact your reseller for support as this upgrade procedure does not apply.

'''Note:''' Sites running on Microsoft Cluster servers should consult the documentation in [[UpgradeNGInACluster | +]].

'''Also see:''' [[UpgradingPaperCut | Common upgrade questions]]

The recommended upgrade procedure is:

->'''1.''' If upgrading from a previous major release (e.g. version 14 or earlier), first [[UpgradePolicy | check your eligibility to upgrade]].

->'''2.''' Schedule appropriate downtime. It is suggested to choose a time of day with minimal network activity. If there is a large volume of data in the system take some time to read this article discussing [[DatabaseUpgrades | database upgrade times]].

->'''3.''' Stop the PaperCut services running in the background. For operating system specific instructions please follow the link [[https://www.papercut.com/products/ng/manual/apdx-tools-start-stop-app.html | here]].

->'''4.''' As a precaution, we recommend backing up the whole PaperCut directory before beginning. Existing overnight backups may have taken care of this task, however take a few moments to create an up-to-date backup now. For example, on Windows, create a zip archive of the directory:
-->[@C:\Program Files\PaperCut NG\@] ([@C:\Program Files\PaperCut MF\@] if using PaperCut MF)

->'''5.''' Run the installer and install into the '''same''' location as the existing install.

->'''6.''' After the install has completed allow a few minutes before accessing the system. The system may need to perform a database upgrade and this will be performed in the background. If you try to access the application while a database upgrade is in progress a message displaying the upgrade status will be displayed. '''IMPORTANT: Do not shutdown the application while an upgrade is in progress. Wait for the upgrade to complete.'''

->'''7.''' Any site servers should now be upgraded to the same version as the primary server. Until they are upgraded, any site servers associated with the primary server will continue to run in offline mode, with reduced functionality.

->'''8.''' It is highly recommended that secondary servers, locally installed user clients, release stations and web print sandbox machines are now upgraded. Basic backwards compatibility for those components is maintained between releases, which allows upgrades involving a large number of servers, or multiple sites, to be staggered, breaking up and localising downtime. Additionally, you will likely not be able to take advantage of new features until all components are upgraded.

->'''9.''' After the install is complete, log into the system and perform some tests to ensure all is working as expected and the system is monitoring user activity as expected. Administrators may find the [[PostUpgradeTestPlan | post upgrade test plan]] useful. Sites running on Novell OES Linux are advised to restart their iPrint Print Manager.

!!Payment Gateway Upgrade and Downloads

!!!PaperCut version 16.2 and above:

-> PaperCut version  16.2 and above are not compatible with older versions of the PaperCut Payment Gateway. You should upgrade to the latest version. Download the latest version from below:

->'''For Windows: '''

-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module.exe|pcng-payment-gateway-module.exe]]

->'''For Mac, Linux and Novell OES: '''

-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module.tar.gz|pcng-payment-gateway-module.tar.gz]]


!!!PaperCut version 15.0 to 16.1:

-> PaperCut version 15.0 to 16.1 are not compatible with older versions of the PaperCut Payment Gateway. You should upgrade to the latest version. Download the latest version from below:

->'''For Windows: '''

-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/ pcng-payment-gateway-module-16.0.225.exe|pcng-payment-gateway-module-16.0.225.exe]]

->'''For Mac, Linux and Novell OES: '''

-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-16.0.225.tar.gz|pcng-payment-gateway-module-16.0.225.tar.gz]]


!!!PaperCut version 14.3 or earlier:

-> Customers running PaperCut 14.3 or earlier can download the payment gateway from here:

->'''For Windows: '''

->[[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-14.3.30038.exe|pcng-payment-gateway-module-14.3.30038.exe]]

->'''For Mac, Linux and Novel OES: '''

-> [[https://cdn.papercut.com/files/pcng/ext/payment-gateway/pcng-payment-gateway-module-14.3.30038.tar.gz|pcng-payment-gateway-module-14.3.30038.tar.gz]]




!!Embedded Devices Upgrade
->PaperCut MF users should now follow any upgrade instructions outlined in the embedded solution documentation for their devices. Your PaperCut reseller may be able to provide an appropriate resource to assist with this procedure.


----
''Categories:'' [[Category.Administration|+]], [[Category.Upgrading|+]]
----
[-Keywords: upgrade, upgrading, instructions, procedure, process, upgrade process, upgrading steps -]

Comments

Share your findings and experience with other PaperCut users. Feel free to add comments and suggestions about this Knowledge Base article. Please don't use this for support requests.

Article last modified on July 23, 2019, at 12:07 PM
Printable View   |   Article History   |   Edit Article