TLS support in PaperCut NG and MF

“Help! As of (insert date), my (insert vendor) will no longer support TLS 1.0 or TLS 1.1 in (insert vendor’s application) and will use TLS 1.2 instead. Is my version of PaperCut NG or MF ready to support the transition?”

So, is my version of PaperCut NG or MF ready to support my vendor’s TLS transition?

Yes, probably!

Starting with PaperCut NG and MF version 15.2 and its Java 8 support, end users benefit from the improved encryption support without a requirement for extra configuration. What this means for end users is that even though your vendor is suspending TLS 1.0 or 1.1 in favor of TLS 1.2, PaperCut NG or MF by default will continue to support connections to their email service, payment gateway, or web browser. To reiterate our point, keep doing what you’re doing since no action is needed for TLS 1.2 support if your PaperCut NG or MF version is 15.2 or better.

However, versions of PaperCut that use Java 7 (v14.0 to v15.1) require specific configuration to support client connections in TLS 1.2. Check out the section Version 14 and above to learn about configuring TLS 1.2 support for these legacy versions of PaperCut.

Do you still have questions?

Let us know! We love chatting about whatโ€™s going on under the hood. Feel free to leave a comment below or visit our Support Portal for further assistance.


Categories: How-to Articles, Security and Privacy


Keywords: TODO keywords here if needed

Comments