PaperCut on Linux errors with "Java heap space"

KB Home   |   PaperCut on Linux errors with "Java heap space"

Main.LinuxJavaHeapSpace History

Hide minor edits - Show changes to output

May 16, 2017, at 04:08 AM by peterf - Updated to reflect 17.1 release
Changed lines 3-4 from:
There have been a few reports of customers running a combination of 32bit Linux Virtual Machines with smaller amounts of System RAM having problems starting later versions of the PaperCut Application Server. This appears to be limited to environments with 2GB or less of System RAM.
to:
There have been a few reports of customers running a combination of 32-bit Linux virtual machines with smaller amounts of system RAM having problems starting later versions of the PaperCut NG or PaperCut MF Application Server. This appears to be limited to environments with 2GB or less of system RAM.
Added lines 11-12:
'''Note:''' As of version 17.1 of PaperCut NG and PaperCut MF, a 32-bit variant for Linux is no longer made available.
Changed lines 15-24 from:
Customers have reported that increasing the amount of System RAM has resolved this issue.

!!Possible resoloution

It is possible that by increasing the RAM fraction that PaperCut has access to that this error may be resolved. Testing of the Java Heap error has not been able to reproduce this issue as at the time of writing so this is something to try if increasing the System RAM is not possible.

PaperCut's Application Server requires at least 192MB of RAM, we would recommend 256MB of RAM or more in most environments. By default PaperCut will use 25% of available system RAM, this means that to meet the minimum requirement of 192MB of RAM, the system should have 768MB system RAM. To meet 256MB you would require 1GB of RAM.

If you can not increase physical RAM, you can try increasing the fraction of available RAM to PaperCut
by following this KB article: [[IncreaseMaxMemoryUsage|+]]
to:
Customers have reported that increasing the amount of system RAM has resolved this issue.

!!Possible resolution

It is possible that this error may be resolved by increasing the RAM fraction that the Application Server has access to. Testing of the Java Heap error has not been able to reproduce this issue as at the time of writing, so this is something to try if increasing the system RAM is not possible.

PaperCut NG and PaperCut MF's Application Server requires at least 192MB of RAM, and we would recommend 256MB of RAM or more in most environments. By default the Application Server will use 25% of available system RAM; this means that to meet the minimum requirement of 192MB of RAM, the system should have at least 768MB of system RAM. To meet 256MB you would therefore require 1GB of RAM.

If you cannot increase the amount of physical RAM, you can try increasing the fraction of RAM available to the Application Server
by following this KB article: [[IncreaseMaxMemoryUsage|+]]
Changed line 28 from:
[-Keywords: -]
to:
[-Keywords: -]
Added lines 1-26:
(:title PaperCut on Linux errors with "Java heap space":)

There have been a few reports of customers running a combination of 32bit Linux Virtual Machines with smaller amounts of System RAM having problems starting later versions of the PaperCut Application Server. This appears to be limited to environments with 2GB or less of System RAM.

Users who have experienced this issue will see similar errors in their [@server.log@] located in [@[app-path]\server\logs\@].

 [@2011-10-17 08:40:27,523 FATAL AppServer:197 - Unable to start
 application server. Java heap space [WrapperSimpleAppMain]
 java.lang.OutOfMemoryError: Java heap space@]

!!Current resolution

Customers have reported that increasing the amount of System RAM has resolved this issue.

!!Possible resoloution

It is possible that by increasing the RAM fraction that PaperCut has access to that this error may be resolved. Testing of the Java Heap error has not been able to reproduce this issue as at the time of writing so this is something to try if increasing the System RAM is not possible.

PaperCut's Application Server requires at least 192MB of RAM, we would recommend 256MB of RAM or more in most environments. By default PaperCut will use 25% of available system RAM, this means that to meet the minimum requirement of 192MB of RAM, the system should have 768MB system RAM. To meet 256MB you would require 1GB of RAM.

If you can not increase physical RAM, you can try increasing the fraction of available RAM to PaperCut by following this KB article: [[IncreaseMaxMemoryUsage|+]]

----
''Categories:'' [[Category.Troubleshooting|+]], [[Category.Linux|+]], [[Category.Error|+]]
----
[-Keywords: -]

Comments

Share your findings and experience with other PaperCut users. Feel free to add comments and suggestions about this Knowledge Base article. Please don't use this for support requests.

Article last modified on May 16, 2017, at 04:08 AM
Printable View   |   Article History   |   Edit Article