Error: cups-api-helper is not optimised for your Mac

KB Home   |   Error: cups-api-helper is not optimised for your Mac

Error: cups-api-helper is not optimised for your Mac and needs to be updated

“This software will not work with future versions of macOS and needs to be updated to improve compatibility. Contact the developer for more information.

You may see this error if you’re running PaperCut NG/MF (including App Server, Secondary Server, Site Server or Direct Print Monitor - in short, if you’ve installed any component that’s monitoring local print queues) on macOS 10.13.4 or later.

Why am I seeing this error?

In short, when running 32-bit apps on macOS 10.13.4 and later, you will see this error appear to remind you that this is a 32-bit app. The cups-api-helper is used by PaperCut to interface with the Printing System on Macs (CUPS).

For a little more info from Apple on this error, take a look at Apple’s support page on the subject.

How can I fix it?

From PaperCut version 19.0.3 and later, we will use a 64-bit version of the cups-api-helper, so you won’t see this message any more.

Upgrade PaperCut to 19.0.3 or later to get rid of this message.

For now, there is no impact other than (as Apple mentions) the message will pop up every 30 days.


Still have questions?

Let us know! We love chatting about what’s going on under the hood. Feel free to leave a comment below or visit our Support Portal for further assistance.


Categories: Troubleshooting, Apple macOS


Keywords: 32-bit, cups helper, cups-helper

Comments

Share your findings and experience with other PaperCut users. Feel free to add comments and suggestions about this Knowledge Base article. Please don't use this for support requests.

Article last modified on April 29, 2019, at 08:09 AM
Printable View   |   Article History   |   Edit Article